mirror of
https://github.com/rtlsdrblog/rtl-sdr-blog.git
synced 2024-11-10 04:37:37 +01:00
8a26abaf79
This allows (among others) to build rtl-sdr nightly packages for a variety of distributions as part of the network:osmocom:nightly builds
13 lines
353 B
Makefile
Executable File
13 lines
353 B
Makefile
Executable File
#!/usr/bin/make -f
|
|
DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
|
|
export DEB_HOST_MULTIARCH
|
|
|
|
%:
|
|
dh $@
|
|
|
|
override_dh_auto_configure: debian/librtlsdr0.udev
|
|
dh_auto_configure -- -DLIB_INSTALL_DIR=lib/$(DEB_HOST_MULTIARCH) -DDETACH_KERNEL_DRIVER=ON
|
|
|
|
debian/librtlsdr0.udev: rtl-sdr.rules
|
|
cp -p rtl-sdr.rules debian/librtlsdr0.udev
|